package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)\[img=\](.*?)\[/img\]`)
var str = `[img width=800,height=531]https://forklog.com/wp-content/uploads/Brisbane-International-Airport.jpeg[/img]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}