import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(push|pop) e(\\w+)";
final String string = "push eax\n"
+ "push ebx\n"
+ "push ecx\n"
+ "push edx\n"
+ "pop eax\n"
+ "pop ebx\n"
+ "pop ecx";
final String subst = "\\1 e\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}