// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(push|pop) e(\w+)").unwrap();
let string = "push eax
push ebx
push ecx
push edx
pop eax
pop ebx
pop ecx";
let substitution = "\\1 e\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}