$re = '/(push|pop) e(\w+)/';
$str = 'push eax
push ebx
push ecx
push edx
pop eax
pop ebx
pop ecx';
$subst = "\1 e\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;