import Foundation
let pattern = #"(push|pop) e(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
push eax
push ebx
push ecx
push edx
pop eax
pop ebx
pop ecx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 e\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)