using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(blogs?|lofiversion|archives?|boards?|groups?|discussions?|forums?|threads?|show(post|thread|topic)|view(thread|topic)|(index\.php))";
string input = @"http://www.hydrogenaud.io/forums/lofiversion/index.php/t48386.html";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}