package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/(blogs?|lofiversion|archives?|boards?|groups?|discussions?|forums?|threads?|show(post|thread|topic)|view(thread|topic)|(index\.php))`)
var str = `http://www.hydrogenaud.io/forums/lofiversion/index.php/t48386.html`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}