re = /\/(blogs?|lofiversion|archives?|boards?|groups?|discussions?|forums?|threads?|show(post|thread|topic)|view(thread|topic)|(index\.php))/
str = 'http://www.hydrogenaud.io/forums/lofiversion/index.php/t48386.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end