import Foundation
let pattern = #"\/(blogs?|lofiversion|archives?|boards?|groups?|discussions?|forums?|threads?|show(post|thread|topic)|view(thread|topic)|(index\.php))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://www.hydrogenaud.io/forums/lofiversion/index.php/t48386.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}