#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?P<startDay>\d{2})\s(?P<finishDay>\d{2})\sdel?\s(?P<month>\d{2})\sdel?\s(?P<year>\d+)"
Local $sString = "05 del 07 del 2000 del 09 hhggh" #example 0 - Not modify!" & @CRLF & _
"04 del 05 del 07 del 2000" #example 1 - Not modify!" & @CRLF & _
"04 05 del 06 de 200" #example 2 - Yes modify!" & @CRLF & _
"04 05 del 06 de 20076 55" #example 3 - Yes modify!"
Local $sSubst = "\g<startDay> \g<finishDay>-\g<month>-\g<year>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)