import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<startDay>\\d{2})\\s(?P<finishDay>\\d{2})\\sdel?\\s(?P<month>\\d{2})\\sdel?\\s(?P<year>\\d+)";
final String string = "05 del 07 del 2000 del 09 hhggh\" #example 0 - Not modify!\n"
+ "04 del 05 del 07 del 2000\" #example 1 - Not modify!\n"
+ "04 05 del 06 de 200\" #example 2 - Yes modify!\n"
+ "04 05 del 06 de 20076 55\" #example 3 - Yes modify!";
final String subst = "\\g<startDay> \\g<finishDay>-\\g<month>-\\g<year>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}