using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<startDay>\d{2})\s(?P<finishDay>\d{2})\sdel?\s(?P<month>\d{2})\sdel?\s(?P<year>\d+)";
string substitution = @"\g<startDay> \g<finishDay>-\g<month>-\g<year>";
string input = @"05 del 07 del 2000 del 09 hhggh"" #example 0 - Not modify!
04 del 05 del 07 del 2000"" #example 1 - Not modify!
04 05 del 06 de 200"" #example 2 - Yes modify!
04 05 del 06 de 20076 55"" #example 3 - Yes modify!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}