// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<startDay>\d{2})\s(?P<finishDay>\d{2})\sdel?\s(?P<month>\d{2})\sdel?\s(?P<year>\d+)").unwrap();
let string = "05 del 07 del 2000 del 09 hhggh\" #example 0 - Not modify!
04 del 05 del 07 del 2000\" #example 1 - Not modify!
04 05 del 06 de 200\" #example 2 - Yes modify!
04 05 del 06 de 20076 55\" #example 3 - Yes modify!";
let substitution = "\\g<startDay> \\g<finishDay>-\\g<month>-\\g<year>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}