#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\n^(?=[a-z])"
Local $sString = "123.- sumi hai" & @CRLF & _
"bla" & @CRLF & _
"124.- the" & @CRLF & _
"secod line" & @CRLF & _
"is blah" & @CRLF & _
"125.- another line"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)