$re = '/\n^(?=[a-z])/m';
$str = '123.- sumi hai
bla
124.- the
secod line
is blah
125.- another line';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;