import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n^(?=[a-z])";
final String string = "123.- sumi hai\n"
+ "bla\n"
+ "124.- the\n"
+ "secod line\n"
+ "is blah\n"
+ "125.- another line";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}