using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n^(?=[a-z])";
string substitution = @" ";
string input = @"123.- sumi hai
bla
124.- the
secod line
is blah
125.- another line";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}