package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(ART\D\d{4}(.*?)\DAND)`)
var str = `ART|3613{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND ART|8923{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}