const regex = /(ART\D\d{4}(.*?)\DAND)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ART\\D\\d{4}(.*?)\\DAND)', 'g')
const str = `ART|3613{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND ART|8923{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}