use strict;
my $str = 'ART|3613{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND ART|8923{"currentTime":"2016-02-29 20:57:06","chat":{"user":"SERVER","msg":"asd"}}|AND';
my $regex = qr/(ART\D\d{4}(.*?)\DAND)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}