// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(ART\D\d{4}(.*?)\DAND)").unwrap();
let string = "ART|3613{\"currentTime\":\"2016-02-29 20:57:06\",\"chat\":{\"user\":\"SERVER\",\"msg\":\"asd\"}}|AND ART|8923{\"currentTime\":\"2016-02-29 20:57:06\",\"chat\":{\"user\":\"SERVER\",\"msg\":\"asd\"}}|AND";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}