using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h2>(.*?)</h2>(.*?)(?=<\w+>)";
string input = @"<h2>1</h2>unstructed string1<h2>2</h2>unstructed string2<div>some data</div>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}