$re = '~<h2>(.*?)</h2>(.*?)(?=<\w+>)~i';
$str = '<h2>1</h2>unstructed string1<h2>2</h2>unstructed string2<div>some data</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);