const regex = new RegExp('<h2>(.*?)</h2>(.*?)(?=<\\w+>)', 'gi')
const str = `<h2>1</h2>unstructed string1<h2>2</h2>unstructed string2<div>some data</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}