re = /<h2>(.*?)<\/h2>(.*?)(?=<\w+>)/i
str = '<h2>1</h2>unstructed string1<h2>2</h2>unstructed string2<div>some data</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end