#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<![\>https?:\/\/|href=\"'])(?<http>(https?:[\/][\/]|www\.)([a-zA-Z0-9\/.&?=-~-]+)*)"
Local $sString = "http://www.webmotors.com.br/comprar/audi/a6/3-0-limousine-v6-30v-gasolina-4p-multitronic/4-portas/2002/13395497"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")