import Foundation
let pattern = #"(?<![\>https?:\/\/|href=\"'])(?<http>(https?:[\/][\/]|www\.)([a-zA-Z0-9\/.&?=-~-]+)*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://www.webmotors.com.br/comprar/audi/a6/3-0-limousine-v6-30v-gasolina-4p-multitronic/4-portas/2002/13395497"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}