using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\>https?:\/\/|href=\""'])(?<http>(https?:[\/][\/]|www\.)([a-zA-Z0-9\/.&?=-~-]+)*)";
string input = @"http://www.webmotors.com.br/comprar/audi/a6/3-0-limousine-v6-30v-gasolina-4p-multitronic/4-portas/2002/13395497";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}