using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:\w+ *){1,5})$";
string input = @"abc def ghi jkl mno
abc def ghi jkl mno pqr
test test tes
test test tse tse tse tes
test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}