// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:\w+ *){1,5})$").unwrap();
let string = "abc def ghi jkl mno
abc def ghi jkl mno pqr
test test tes
test test tse tse tse tes
test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}