package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\w+ *){1,5})$`)
var str = `abc def ghi jkl mno
abc def ghi jkl mno pqr
test test tes
test test tse tse tse tes
test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}