$re = '/^((?:\w+ *){1,5})$/m';
$str = 'abc def ghi jkl mno
abc def ghi jkl mno pqr
test test tes
test test tse tse tse tes
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);