using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<:([^<:>\s]+?):>";
string input = @"regex is /<:([^<:>\s]+?):>/gm
Define custom tag : <:tag_name:>
prefix is ""<:""
suffix is "":>""
tag_name can not contain prefix, suffix, space, tab or newline character.
tag_name can not be null.
test string as below:
<:ab我c:><<:abc:>:<:ab_c:>a<:ab c:>b<:abc:><:abc:>c:<:abc:>><:abc:>
<:<:efg<:efg:>:>e<:<:efg<:ef g:>:>efg<:<:efg:>efg:>:>fg<:<:efg:>efg:>:>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}