const regex = /<:([^<:>\s]+?):>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<:([^<:>\\s]+?):>', 'gm')
const str = `regex is /<:([^<:>\\s]+?):>/gm
Define custom tag : <:tag_name:>
prefix is "<:"
suffix is ":>"
tag_name can not contain prefix, suffix, space, tab or newline character.
tag_name can not be null.
test string as below:
<:ab我c:><<:abc:>:<:ab_c:>a<:ab c:>b<:abc:><:abc:>c:<:abc:>><:abc:>
<:<:efg<:efg:>:>e<:<:efg<:ef g:>:>efg<:<:efg:>efg:>:>fg<:<:efg:>efg:>:>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}