// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<:([^<:>\s]+?):>").unwrap();
let string = "regex is /<:([^<:>\\s]+?):>/gm
Define custom tag : <:tag_name:>
prefix is \"<:\"
suffix is \":>\"
tag_name can not contain prefix, suffix, space, tab or newline character.
tag_name can not be null.
test string as below:
<:ab我c:><<:abc:>:<:ab_c:>a<:ab c:>b<:abc:><:abc:>c:<:abc:>><:abc:>
<:<:efg<:efg:>:>e<:<:efg<:ef g:>:>efg<:<:efg:>efg:>:>fg<:<:efg:>efg:>:>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}