import re
regex = re.compile(r"<:([^<:>\s]+?):>", flags=re.MULTILINE)
test_str = ("regex is /<:([^<:>\\s]+?):>/gm\n"
"Define custom tag : <:tag_name:>\n"
"prefix is \"<:\"\n"
"suffix is \":>\"\n"
"tag_name can not contain prefix, suffix, space, tab or newline character.\n"
"tag_name can not be null.\n\n"
"test string as below:\n\n"
"<:ab我c:><<:abc:>:<:ab_c:>a<:ab c:>b<:abc:><:abc:>c:<:abc:>><:abc:>\n"
"<:<:efg<:efg:>:>e<:<:efg<:ef g:>:>efg<:<:efg:>efg:>:>fg<:<:efg:>efg:>:>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")