#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)import\s+com.+?\.([a-zA-Z]+Factory\.class).*(\1)"
Local $sString = "import com.sample.OtherClass;" & @CRLF & _
"import com.sample.cool.SomeFactory.class;" & @CRLF & _
"" & @CRLF & _
"// other nonsense" & @CRLF & _
"" & @CRLF & _
"@Import(clazz = SomeFactory.class)" & @CRLF & _
"// other nonsense"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")