$re = '/(?s)import\s+com.+?\.([a-zA-Z]+Factory\.class).*(\1)/';
$str = 'import com.sample.OtherClass;
import com.sample.cool.SomeFactory.class;
// other nonsense
@Import(clazz = SomeFactory.class)
// other nonsense';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);