const regex = /(?s)import\s+com.+?\.([a-zA-Z]+Factory\.class).*(\1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)import\\s+com.+?\\.([a-zA-Z]+Factory\\.class).*(\\1)', 'g')
const str = `import com.sample.OtherClass;
import com.sample.cool.SomeFactory.class;
// other nonsense
@Import(clazz = SomeFactory.class)
// other nonsense`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}