re = /(?s)import\s+com.+?\.([a-zA-Z]+Factory\.class).*(\1)/
str = 'import com.sample.OtherClass;
import com.sample.cool.SomeFactory.class;
// other nonsense
@Import(clazz = SomeFactory.class)
// other nonsense'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end