#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).*\n(start.*)"
Local $sString = "total abc total foo total anything here total" & @CRLF & _
"total total" & @CRLF & _
"total" & @CRLF & _
"start" & @CRLF & _
"otal abc total foo total anything here total" & @CRLF & _
"otal abc total foo total anything here total" & @CRLF & _
"start" & @CRLF & _
"otal abc total foo total anything here total" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")