import re
regex = re.compile(r".*\n(start.*)", flags=re.DOTALL)
test_str = ("total abc total foo total anything here total\n"
"total total\n"
"total\n"
"start\n"
"otal abc total foo total anything here total\n"
"otal abc total foo total anything here total\n"
"start\n"
"otal abc total foo total anything here total\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")