package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).*\n(start.*)`)
var str = `total abc total foo total anything here total
total total
total
start
otal abc total foo total anything here total
otal abc total foo total anything here total
start
otal abc total foo total anything here total
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}