re = /.*\n(start.*)/
str = 'total abc total foo total anything here total
total total
total
start
otal abc total foo total anything here total
otal abc total foo total anything here total
start
otal abc total foo total anything here total
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end