#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z0-9]+(?!.*(?:\+{2,}|\-{2,}|\.{2,}))(?:[\.+\-]{0,1}[a-z0-9])*@gmail\.com$"
Local $sString = "niceandsimple@gmail.com" & @CRLF & _
"very.common@gmail.com" & @CRLF & _
"disposable.style.email.with+symbol@gmail.com" & @CRLF & _
"other.email-with-dash@gmail.com" & @CRLF & _
"invalid--email@gmail.com" & @CRLF & _
"invalid++email@gmail.com" & @CRLF & _
"invalid..email@gmail.com" & @CRLF & _
"-invalid-email@gmail.com" & @CRLF & _
"invalid--email-@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")