import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]+(?!.*(?:\\+{2,}|\\-{2,}|\\.{2,}))(?:[\\.+\\-]{0,1}[a-z0-9])*@gmail\\.com$";
final String string = "niceandsimple@gmail.com\n"
+ "very.common@gmail.com\n"
+ "disposable.style.email.with+symbol@gmail.com\n"
+ "other.email-with-dash@gmail.com\n"
+ "invalid--email@gmail.com\n"
+ "invalid++email@gmail.com\n"
+ "invalid..email@gmail.com\n"
+ "-invalid-email@gmail.com\n"
+ "invalid--email-@gmail.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}