import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(?:\\.(?:exe|sh|js|bat)(?:\\.|$))).*\\.(?:pdf|xls)$";
final String string = "file.pdf\n"
+ "file.xls\n"
+ "i want to exclude\n"
+ "file.sh\n"
+ "file.exe\n"
+ "file.js\n"
+ " or \n"
+ "file.bat\n"
+ "filename.exe.pdf\n\n"
+ "screenshot.pdf\n"
+ "nexe.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}