$re = '/^(?!.*(?:\.(?:exe|sh|js|bat)(?:\.|$))).*\.(?:pdf|xls)$/m';
$str = 'file.pdf
file.xls
i want to exclude
file.sh
file.exe
file.js
or
file.bat
filename.exe.pdf
screenshot.pdf
nexe.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);