re = /^(?!.*(?:\.(?:exe|sh|js|bat)(?:\.|$))).*\.(?:pdf|xls)$/m
str = 'file.pdf
file.xls
i want to exclude
file.sh
file.exe
file.js
or
file.bat
filename.exe.pdf
screenshot.pdf
nexe.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end