import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(in)(?=\\s*\\d+)|' time";
final String string = "2014/12/04 Test in 1 day' time 0 weeks\n"
+ "2014/12/07 Amazon Prime Ends in 95 days | 13 weeks\n"
+ "2014/12/24 Christmas in China in 112 days | 16 weeks";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}